Jump to content

Search the Community

Showing results for tags 'station'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Welcome To The Netweather Community - Weather Forum
    • News & Announcements
    • Help, support and feedback
    • Weather Forecasts, Alerts and News from Netweather
  • General Weather Discussion
    • Spring and General Weather Discussion
    • Forecast models, atmosphere, stratosphere & global drivers
    • Regional Discussions
    • Storms & Severe Weather Discussion
    • Hurricane watch
    • Weather Around The World
    • Learning about weather and meteorology
    • Weather Photography
    • Storm Chase USA
  • Climate and Science
    • Climate Change - The Science
    • Space, Science & nature
  • Community Area
    • The Lounge
    • Serious discussion
    • The sports zone
    • Travel, Holidays and Days Out
    • The Techies
    • Photography
  • Netweather Community Archives
    • Forum Archive
  • SACRA's Snow Chat

Categories

  • Articles

Found 1 result

  1. Hello I was wondering if anyone can offer some advice on how to solve a problem with the temperature gauge on my weather station? I have one of these https://www.maplin.co.uk/p/maplin-professional-solar-powered-wi-fi-weather-station-n23dq and the temperature sensor seems to have gone. It's currently reading 19.5c, when actually it's 11c. It has been like this for a few weeks, so I contacted Maplins to see if they could direct me towards spares, as it is out of warranty. They have come back via email today saying they do not keep spares or know where to get them from. Any advice on spares or how to get it working? Thanks in advance Darren
×