Jump to content
Holidays
Local
Radar
Snow?

PMPhotography

Members
  • Content Count

    552
  • Joined

  • Last visited

Community Reputation

171 Excellent

Profile Information

  • Gender
    Male
  • Location
    Scarborough, North Yorkshire - 68m ASL

Contact Methods

Recent Profile Visitors

9,655 profile views
  1. I've had the Davis Vantage Vue for about 5 years now. Never had any issues with it, it's been well maintained and survived 2 house moves! Noticed a couple of weeks ago one of the wind cups had snapped off. I've brought it off the roof, done the usual maintenance, replaced the cups and added new C123 lithium battery. Since changing the battery I've struggled to get any signal. When the console receives data it's ridiculous values (68c temp etc). The station is transmitting on 1. Now here's what I cant get my head around... The station transmits for a few seconds AFTER adding the new backup battery, then it dies. I left the backup battery out of the transmitter last night, and put the station out again, no data received overnight. This morning its receiving data again, obviously the solar element is working fine. It all seems very backwards to my simple brain! Is it possible to have failure of the backup battery component? And I've used 3 different batteries so no issues with them! Any advice would be massively appreciated!
  2. I've had the Davis Vantage Vue for about 5 years now. Never had any issues with it, it's been well maintained and survived 2 house moves! Noticed a couple of weeks ago one of the wind cups had snapped off. I've brought it off the roof, done the usual maintenance, replaced the cups and added new C123 lithium battery. Since changing the battery I've struggled to get any signal. When the console receives data it's ridiculous values (68c temp etc). The station is transmitting on 1. Now here's what I cant get my head around... The station transmits for a few seconds AFTER removing the backup battery, then it dies. I left the backup battery out of the transmitter last night, and put the station out again, no data received overnight. This morning its receiving data again, obviously the solar element is working fine. It all seems very backwards to my simple brain! Is it possible to have failure of the backup battery component? And I've used 3 different batteries so no issues with them! Any advice would be massively appreciated!
  3. Eerie skies and a covering of hail as wintry showers push in Scarborough.
  4. Yellow warning and light showers forecast here overnight. Not expecting much but then I wasn't last week!
  5. A few shots from today's snow and surge from Scarborough.
  6. It's a shame the back end seems to be more sleet/ rain. Wintry showers following on for the coast. Metoffice seem to have removed the snow warning now for tomorrow. Still in place for Saturday.
  7. It will be. I'm at work all flaming day! Here's a couple more from today.
  8. Hopefully we'll get some decent snow showers here on the coast when the northerly kicks in on Friday. Met warnings for the coast so hopefully not a marginal situation! I feel snow may be overshadowed here by the immense sea's expected. High tide Friday pm is at 6.07m. Storm jude was 6.34 and there's a he'll of a lot more fetch this time. Surge with 13-15ft swells expected. These pics are from today with tide at 5.9m and a westerly!
  9. First dusting of the winter here in scarborough! At last. Plenty more showers incomong on radar too.
  10. Had a couple of light flurries overnight from coastal showers, amounting to nothing really! Pretty cold this morning at -2.2C. Great to see most of the region got some snow last night! Send a bit this way next time though!!
  11. Just a single degree cooler it eould have been snowfest here in scarborough!! Been sleet and wet snow all day. Racked up 13.4mm so far and still coming down. Some local accumulations causing bother on the roads. As i said earlier though. The winds been the main issue with numerous trees down. This one from hackness. Edit - eyms busses just tweeted victoria road closed due to structural damage to a building!
  12. Sweet! Saw your vid. Looks ace... 8mm of wet slush fallen so far today! What a waste!! Doesn't even look like any coastal showers after the band which was initially forecast. (thats what i was pinning my hopes on!!)
  13. It's certainly trying here in scarborough. Im at 68m asl wet snow now. Not settling. Dew point 1.7c but dropping. Its blowing like mad though!
×
×
  • Create New...